IE Processes don't stop after exiting CCA

Oct 21, 2010 at 10:45 AM

Hi!

 

I have a problem with the agent desktop I'm implementing. If I open a Session with a Web Hosted Application which redirects from a blank url to the correct url, and then exit the agent desktop, there are several IE Processes listed in the taskmanager. This happens all the time I open Sessions with Web Hosted Apps.

 

I would be thankful if someone could help me

Oct 22, 2010 at 8:06 AM

Hello maniga

In my environment this problem exists only in the case I have some opened IE windows. Close all your opened IE windows and try to open and close CCA session.
I think IE processes must automatically be closed in this case.

Vahag.

Apr 28, 2011 at 7:23 PM

I had the sane problem!

The iexplorer.exe processes just exit if i close in the task manager.

Matt can you help us?

May 3, 2011 at 3:05 PM

General there are only two reasons you would end up with ghost IE Processes…

1)      In a Dev environment you stopped the shell via VS’s Debugger .
2)      In your code you are creating an instance of WebBrowserExtended on your own and not cleaning it up on shutdown.

Aside from that, it should not happen… The Crash logic in UII should fire and close IE if an exception shuts the shell down.
If you are doing debugging, its very important that you let the shell run all the way to close, or clean up IE after your dev session so that you done end up with strange behavior in IE.

Mattb-msft

Dec 16, 2011 at 11:57 AM
Edited Dec 16, 2011 at 11:57 AM

Has there been any further progress on this issue?  We're getting prolific IE processes left behind by each session created.  We have 10 - 15 browser tabs created per session, and there can be 5 or 6 orphaned IE processes.  This is not using our own WebBrowserExtended control, and not running in a Debugger.  Eventually, the Agent Desktop crashes due to out of memory issues.

Dec 16, 2011 at 2:06 PM

Could you tell me more about the controls your using, and how you are invoking them?
also what version of IE / What OS?

Dec 16, 2011 at 2:24 PM

Standard Web Hosted Application, using SetParent, default URL is about:blank, Use New Browser Process is Unticked, default UII Action is to navigate to a page including information from the context (for instance, an account using an account GUID).

Desktop is typically a Win 7 64 bit client, though it's happening on XP and Vista 32 bit systems as well, using IE 8 or IE 9.

Dec 16, 2011 at 2:40 PM

I have noticed this behaviour with XP and IE8.  But this is standard behaviour of IE8 and XP.  Unless the last IE process is closed , Iexplore.exe remains in task manager. So after closing AD, check if you have any IE instance open. Close that and check all Iexplore gets closed in Task manager. This can be noticed without AD as well.

 

Not sure about other OS's.

Dec 16, 2011 at 4:07 PM

LazerFX, if this is related to your other post about Instances of IE hung off SvcHost  then Please see my comment about protected mode.

Mattb-MSFT.

Dec 16, 2011 at 4:25 PM

It is, and I have responded in that thread.  For ease for anyone else following this conversation, http://crmcca.codeplex.com/discussions/230558 is the location of the thread currently.

Thanks,

Peter

Mar 23, 2012 at 12:48 PM

Hi All,

IE Processes don't stop after exiting CCA is resolved by

Opening CCA with admin permission( Right click the agent desktop &click  "Run as admin")


Thanks,

Akilan

Apr 12, 2012 at 9:33 AM
Edited Apr 14, 2012 at 9:46 AM

Hi,

I had the same issue, and in addition to AKILAN's workaround, another workaround is to enable protected mode in Internet Explorer:

1) In IE, Tools --> Internet Options
2) Open Security Tab
3) Select the applicable Zone (i.e. the zone where the hosted web-app:s URL applies to)
4) Check the "Enable Protected Mode" option

After I did this the iexplorer processes shut down properly. I did not have to start the desktop with admin persmissions.

BR,
Johan

****** Edit *********
After reading the thread http://crmcca.codeplex.com/discussions/230558 it seems like the protected mode option is kind of "old stuff". Sorry for this. 

But, for curiosity (and maybe off-topic) -  I wonder what the protected mode really does when it obviously solved my problem with ghost ie-processes. The url:s that I opened were CRM-pages in the local intranet zone. Option "Use new browser process" was checked for the [CRM] webapp. No workflows etc, just started the app as a dynamic application from code (similar approach to the app-menu implementation in the CCA R2 Desktop). The default action built the querystring based on a context variable (i.e. read the CustomerId). The reason to why I selected "Use new broser process" in the first place was that I was experiencing trouble with the SSO process to the CRM application without having this option selected (got a blank screen sometimes - especially when I was working from home via a VPN tunnel). After I selected the protected mode, I unchecked the "Use new browser process" option and everything was working fine with the SSO - both from home and when I was on-site. And, as I mentioned earlier - when having the "Use new browser process" option checked the ie-processes was shutting down fine.

I understand there might be various reasons to this behaviour (my own bugs, CRM config, AD config, VPN Config, OS Config etc.) and the subject might be a bit off-topic. But, if anybody has knowledge or directions/guidelines/"do:s and don't::s" regarding this and on how to combine these different configuration options it would be much appreciated.

Thanks for a great forum!

BR,
Johan

***********