DDA0100: Unable to find control on the user interface.

Jun 8, 2010 at 12:58 PM
Edited Jun 10, 2010 at 1:49 PM

I create application from example and i run it on my IAD.

But i have exception :

6/8/2010 4:17:41 AM: Notepad: WF/Automation 1662f0b1-cb44-4468-9a26-ae7ae95c25a3 started: application=Notepad,action=default,data=,async=False 

6/8/2010 4:17:43 AM: Live: AutomationAdapter (app=Live,action=__SetControlValue__): Posted implicit action exception: Microsoft.Uii.HostedApplicationToolkit.DataDrivenAdapter.DataDrivenAdapterException: DataDrivenAdapterException (op=FindControl,controlName=InputElement): DDA0100: Unable to find control on the user interface. 

6/8/2010 4:17:43 AM: Notepad: WF/Automation 1662f0b1-cb44-4468-9a26-ae7ae95c25a3 exception: Microsoft.Uii.HostedApplicationToolkit.DataDrivenAdapter.DataDrivenAdapterException: DataDrivenAdapterException (op=FindControl,controlName=InputElement): DDA0100: Unable to find control on the user interface.   at Microsoft.Uii.HostedApplicationToolkit.AutomationHosting.AutomationAdapter.AdapterFireActionFromAutomation(String applicationName, String actionName, Object data)   at Microsoft.Uii.HostedApplicationToolkit.AutomationHosting.AutomationBridgeService.SetControlValue(String applicationName, String controlName, String controlValue)   at Microsoft.Uii.HostedApplicationToolkit.Activity.SetControlValue.ExecuteImpl(ActivityExecutionContext context, AutomationBridgeService service)   at Microsoft.Uii.HostedApplicationToolkit.Activity.HatActivityBase.Execute(ActivityExecutionContext executionContext)   at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext)   at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(Activity activity, ActivityExecutionContext executionContext)   at System.Workflow.ComponentModel.ActivityExecutorOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime)   at System.Workflow.Runtime.Scheduler.Run() 

6/8/2010 4:17:43 AM: Notepad: WF/Automation 1662f0b1-cb44-4468-9a26-ae7ae95c25a3 terminated (duration 2324ms): data= 

6/8/2010 4:17:46 AM: Live: WF/Automation 6d38ea6d-f544-48d6-8a4c-b710468c7ac2 started: application=Live,action=default,data=,async=False 

 

I recreated controls and workflow but it doesn't resolve my issue.

Thank you for any help.

 

Jun 15, 2010 at 2:43 PM

I'm recreated my application and workflow.

Now it works on startup. (Exception still exist in log.)

But when i creat new workflow to put some text in my notepad application and make it's as workflow in IAD - nothing happen when i run workflow step.

Jun 17, 2010 at 2:14 PM

Can you describe the automation your trying to create?
What do you want to do?

MattB-MSFT

Jun 21, 2010 at 9:51 AM
Edited Jun 21, 2010 at 2:48 PM

Hi Matt B.

Thanks for the reply.

I want to put some text in notepad. Now i resolve this problem.

Now i try to make another application and automation (workflow in future).

I need to make integration with Micrososft Excel.

I make new automation to test it - execute action "Bold" (i want to "Bold" button presed when my application will start).

And i have same exception: DDA0100: Unable to find control on the user interface.

(Excel start in IAD but my action doesn't cmplete)

 

Finally i need to take data from excel cells and put it on crm.

 

 

 

Jun 21, 2010 at 11:31 AM

Is Excel opening inside CCA or outside?
And did you inspect it via the HAT Inspector?

For access to cells..
The way I would do that would be to use a Hosted Control and the Office Automation API, and likely manage re-parenting the UI myself ( but that’s me
J ). However you could also write an extended DDA that would talk to the Excel Automation API to do the same.

Matt B.

Jun 21, 2010 at 11:52 AM

Sometimes Excel open inside CCA and sometimes outside, but i have exception anyway.

I inspect excel using ApplicationInspector which inside Visual Studio.

Now i Found "HAT Test Harness" and try to inspect excel with this tool.

I think first way will be easy for me - use Office Automation API - it's must be installed additionally?

Jun 21, 2010 at 1:36 PM
Edited Jun 21, 2010 at 1:37 PM

What version of office are you using? The API answer is a bit different based on version.

I figured that was happening.
Excel uses’ a loader to get started.. so when you click Excel.exe you’re really starting the loader.. You need to catch the main window. There are some tweaks to the HAT Config for the entry that you can do to make that work better. Also you will need to set the window name and acquire timeout’s in UII Config for that application.

You can find the main window name using UISpy ( on Vista / W7 + VS2008 ) or regular old Spy ++

Out of curiosity.. could you PM me with your use case? It’s somewhat unusual to see Excel used with CCA as a Hosted application.

MattB.

Jun 22, 2010 at 9:01 AM

I'm use office 2007.

I put window class "XLMAIN" and acquire timeout  "20000" (20 seconds) in UII Config of my aplication - now it always start inside CCA!

Using "HAT Test Harness" i test my Excel control - it works fine but in Automation it still doesn't work.

Maybe automation try to make action before Excel sucessfully loaded in  CCA? When i debug automation - it starts 4 or 5 times while all my hosted aaplication (Excel, Notepad, Yandex, CRM,CRM) loading.

Excel actions state at the end of Automation.

 

Jun 22, 2010 at 1:10 PM

Yep,

You need a default Automation before your main
if you’re not going to register any events for it, the simplest way to do it is to create an Action in UII admin for your project called “Default” and set the Default switch to true.

Once your app is up and running you can use the UII Debugger (found in the Quickstarts projects) to run your action, tied to the automation, for testing.

When your ready to use it, you can invoke your action from an event, or you can attach it to a workflow

 

Matt B.

Jun 28, 2010 at 3:14 PM
Edited Jun 28, 2010 at 3:20 PM

Hi.

I'm used Uii Debugger and it works fine for Notepad and Yandex applications.

But in Excel i still have same error.

I add new action in Excel hosted aplication, but then i try execute it with Uii debigger "Unable to find control on the user interface" appears again.