Cca: Unable to login. Not a valid organization service URI

Oct 5, 2011 at 10:35 AM

Hi,

I have compiled CCA, I have obtained AgentDesktop.exe and when executing it, I introduced valid authentication parameters, but I obtained the following exceptions in CCA.log file:

10/05/2011 16:13:56: CCA: Agentdesktop starting...
10/05/2011 16:14:00: Cca: Unable to login - Please make sure your login details are correct and try again. Contact administrator if the problem persists.
System.ArgumentException: Not a valid organization service URI.
   РІ Microsoft.Uii.AifServices.AuthenticationService.Connect(Uri organizationServiceUri, NetworkCredential networkCredential)
   РІ Microsoft.Crm.Accelerator.Cca.WpfDesktop.MainWindow..ctor()
10/05/2011 16:14:02: CCA: Agentdesktop exited.

 

App.config

...    <appSettings>
        <!-- General settings for Agent Desktop -->
        <add key="LoadSessions" value="false"/>
        <add key="showSplashScreen" value="true"/>
    <add key="appname" value="Application"/>
    <add key="logname" value="Customer Care Accelerator"/>
    <add key="authenticationMode" value="Custom"/>
    <add key="organizationServiceUrl" value="http://brn-crm-1/PRAKTIKACRM/XRMServices/2011/organization.svc"/>
  </appSettings>

Can you help me please ?

Thank you very much in advance

Oct 6, 2011 at 3:47 AM

Its been a long time since Iv used the Default Login process for CCA, however..

I believe the issue is the authenticationMode key.

For windows it should read : windows

For Online it should read: online

For Federation it should read : federation

Custom would mean "roll your own"

 

Mattb-MSFT

Oct 6, 2011 at 5:59 AM

for authenticationMode = Windows the error remains

Oct 6, 2011 at 7:23 AM
Case is important I think. Also you can debug the login process in the shell..

Mattb

Sent from my Windows Phone

From: Alkali
Sent: 10/5/2011 11:59 PM
To: mattb-msft@hotmail.com
Subject: Re: Cca: Unable to login. Not a valid organization service URI [crmcca:274818]

From: Alkali

for authenticationMode = Windows the error remains

Oct 6, 2011 at 8:32 AM

error at line 149 in MainWindow.xaml.cs

 

"authenticationService.Connect(new Uri(organizationServiceUrlString),
                                            new NetworkCredential(loginForm.UserName, loginForm.Password, loginForm.DomainName));"