CCA Stoped working

Jun 7, 2011 at 9:04 PM

Hi I have installed CCA, and it was working fine.

But I have installed Outlook 2010 and configured Outlook with CRM. As soon as I did this, CCA start throwing this error:

07/06/2011 1:15:18 PM: CCA: Sessions.CloseSession: Closing session: ''
07/06/2011 1:15:18 PM: CCA: Agentdesktop exited.
07/06/2011 1:18:58 PM: CCA: Agentdesktop starting...
07/06/2011 1:18:58 PM: CCA: Unable to load DLL 'windowsaccessbridge.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
07/06/2011 1:18:59 PM: CCA: Sessions.AddSession: Adding new session: ''
07/06/2011 1:18:59 PM: CCA: Sessions.SetActiveSession: Switching to session: ''
07/06/2011 1:19:13 PM: Application Host: APPLICATION_HOST_ERR_NO_CONFIGURED_APPS: No applications are configured for your use.
 
07/06/2011 1:19:16 PM: CCA: Sessions.CloseSession: Closing session: ''
07/06/2011 1:19:16 PM: CCA: Agentdesktop exited.

I have checked the Microsoft Dynamics CRM Asynchronous Processing Service on crm server, it is running.

I am running CCA on windows 7 with IE8. Please let me know How can I resolve this issue?

Regards,

Naqvi

Jun 8, 2011 at 1:26 PM

You can ignore this error :
07/06/2011 1:18:58 PM: CCA: Unable to load DLL 'windowsaccessbridge.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)

This Error is what you’re looking at..
07/06/2011 1:19:13 PM: Application Host: APPLICATION_HOST_ERR_NO_CONFIGURED_APPS: No applications are configured for your use.

It would indicate that the user account your using to connect to CRM from your client does not have access to UII’s configuration. Make sure the UIIAgent Role is assigned to either the team that this user is a member of or that its assigned to the user itself.

MattB

Sep 20, 2012 at 6:55 AM

Hello,

I am also facing the same issue -

 

Exception

System.DllNotFoundException occurred
  Message=Unable to load DLL 'windowsaccessbridge.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
  Source=AgentDesktop
  TypeName=""
  StackTrace:
       at Microsoft.Crm.Accelerator.Cca.WpfDesktop.Program.Windows_run()
       at Microsoft.Crm.Accelerator.Cca.WpfDesktop.Program.Main() in C:\Program Files\Microsoft UII\CCA\Source Code\AgentDesktop\Program.cs:line 82
  InnerException:

 

And

9/20/2012 11:37:12 AM: CCA: Agentdesktop starting...
9/20/2012 11:37:12 AM: CCA: Unable to load DLL 'windowsaccessbridge.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
9/20/2012 11:39:35 AM: CCA: Sessions.AddSession: Adding new session: ''
9/20/2012 11:39:35 AM: CCA: Sessions.SetActiveSession: Switching to session: ''
9/20/2012 11:39:40 AM: ApplicationHost: ApplicationHost: Loading app=Application Explorer type=HostedControl
9/20/2012 11:39:40 AM: ApplicationHost: ApplicationHost: Loading app=AspectUserControl type=HostedControl
9/20/2012 11:39:43 AM: ApplicationHost: ApplicationHost: Loading app=Current Session Viewer type=HostedControl
9/20/2012 11:39:43 AM: ApplicationHost: ApplicationHost: Loading app=Customer Search type=HostedControl
9/20/2012 11:39:43 AM: ApplicationHost: ApplicationHost: Loading app=Session Tabs type=HostedControl
9/20/2012 11:39:43 AM: ApplicationHost: ApplicationHost: Loading app=Workflow Explorer type=HostedControl
9/20/2012 11:39:44 AM: ApplicationHost: ApplicationHost: Loading app=Workflow Manager type=HostedControl
9/20/2012 11:39:44 AM: ApplicationHost: ApplicationHost: Loading app=CRM Knowledge Base type=WebHosted
9/20/2012 11:39:44 AM: CCA: WF/AutomationManager startup completed
9/20/2012 11:39:44 AM: CRM Knowledge Base: AutomationAdapter (session=6100830d-92a0-4df0-ba4f-9c06b17b2f27, app=CRM Knowledge Base): Initialized
9/20/2012 11:39:44 AM: CRM Knowledge Base: AutomationAdapter (session=6100830d-92a0-4df0-ba4f-9c06b17b2f27, app=CRM Knowledge Base): ContextChange(): context=<UiiContext />
9/20/2012 11:39:54 AM: CRM Knowledge Base: APPLICATION_HOST_ERR_IN_DO_ACTION: An error has occurred while performing action on the hosted application CRM Knowledge Base.
System.Runtime.InteropServices.COMException (0x800704A6): Creating an instance of the COM component with CLSID {0002DF01-0000-0000-C000-000000000046} from the IClassFactory failed due to the following error: 800704a6.
   at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck)
   at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache)
   at System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean skipCheckThis, Boolean fillCache)
   at System.Activator.CreateInstance(Type type, Boolean nonPublic)
   at System.Activator.CreateInstance(Type type)
   at Microsoft.Uii.Csr.Browser.Web.WebBrowserExtended.StartBrowser(String urlString)
   at Microsoft.Uii.Csr.Browser.Web.WebBrowserExtended.PerformNavigate(String urlString, Boolean newWindow, String targetFrameName, Byte[] postData, String headers)
   at Microsoft.Uii.Csr.Browser.Web.WebBrowserExtended.Navigate(String urlString)
   at Microsoft.Uii.Csr.HostedWebApplication.DoDefaultAction()
9/20/2012 11:39:59 AM: CCA: Sessions.CloseSession: Closing session: ''
9/20/2012 11:39:59 AM: CRM Knowledge Base: AutomationAdapter (session=6100830d-92a0-4df0-ba4f-9c06b17b2f27, app=CRM Knowledge Base): Closed
9/20/2012 11:39:59 AM: CCA: Agentdesktop exited.

 

Sep 20, 2012 at 9:57 AM
Edited Sep 20, 2012 at 9:59 AM

A restart to computer resolved the issue -

System.Runtime.InteropServices.COMException (0x800704A6): Creating an instance of the COM component with CLSID {0002DF01-0000-0000-C000-000000000046} from the IClassFactory failed due to the following error: 800704a6

This may be because of windows update. Post update a restart was required.

Agent Desktop running now!!.