Could not load type 'Microsoft.Uii.Customization.LandingPage'

May 17, 2010 at 5:48 AM
Edited May 17, 2010 at 7:15 AM

After installing CCA on server as described in the Installation Manual, when i try to open the uii_settings entity in CRM , iam getting the crm error.

So i decided to run the landing page from the server iis. The error iam getting is "

Could not load type 'Microsoft.Uii.Customization.LandingPage

Pls suggest solution for this.





May 17, 2010 at 10:18 PM

You need to run that inside CRM’s Application..
Based on your symptom, It sounds like the CRM Customizations didn’t install correctly.

I would suggest that you run the install in Custom mode, and remove just the CRM Extensions, then Re-add them.

May 18, 2010 at 8:07 AM

I did all the things you mentioned above. Now i am not getting the "Could not load type 'Microsoft.Uii.Customization.LandingPage" error.

Now iam getting 401 unauthorized error when viewed in my stack trace. Note: iam running this in IFD mode.

What are all the permissions to be given for that uii and its subfolder to get rid of this issue.

Pls suggest.


May 19, 2010 at 2:53 AM

Hey ,

Which server OS are you running?

Is it setup for IFD only or IFD +onPremise? The difference is the subnet mask ,while configuring the setup with the IFD tool . the subnet mask means , its IFD only. We recommend IFD+OnPremise deployment.

Alos, which server name did you give during installation ?

Here are few trouble shooting steps for IFD setup .

1. For UII , we need the http://servername:port/OrganizationName/loader.aspx: resolve to your localhost , not the IFD URL.  You can verify this from the browser on the server machine . If it redirects to the IFD Url, the landing page may not work correctly or you get http 401 unauthorized error. 

2. Please follow this link , to setup the loopback address.

If this is the issue, please set the loopback address and re run the installation.

Hope this helps. If the issue is still not resolved, let me know the exact problem you are facing.



May 19, 2010 at 3:27 PM

Additionally, CRM 4.0 has no support for IPv6.

So, if your CRM server is configured for Windows Server 2008 , please disable IPv6. Else, plugin registration will not succeed.

May 24, 2010 at 9:39 AM
Edited May 24, 2010 at 11:48 AM

Hi Prashas616,

I tried all possible solutions on accessing the uii setting in ifd mode(multiple organizations environment)

Pls find below stack trace captured while accessing uii setting.

at ErrorInformation.LogError()
at ErrorInformation..ctor(Exception exception, Uri requestUrl, Boolean logError)
at ErrorInformation..ctor(Exception exception, Uri requestUrl)
at MainApplication.Application_Error(Object sender, EventArgs eventArguments)
at EventHandler.Invoke(Object sender, EventArgs e)
at HttpApplication.RaiseOnError()
at HttpApplication.RecordError(Exception error)
at ApplicationStepManager.ResumeSteps(Exception error)
at HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)
at HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
at HttpRuntime.ProcessRequestNoDemand(HttpWorkerRequest wr)
at ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)
>MSCRM Error Report:
Error: Exception of type 'System.Web.HttpUnhandledException' was thrown.
Error Message: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
Error Details: Exception of type 'System.Web.HttpUnhandledException' was thrown.
Source File: Not available
Line Number: Not available
Request URL: http://servername:5555/ISV/UII-ISV/Microsoft.Uii.Customization/LandingForm.aspx?orgname=testorg&userlcid=1033&orglcid=1033
Stack Trace Info: [WebException: The request failed with HTTP status 401: Unauthorized.]
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Microsoft.Crm.SdkTypeProxy.Metadata.MetadataService.Execute(MetadataServiceRequest Request)
at Microsoft.Uii.Customization.LandingPage.RetrieveEntities(String[] entityMetaDataNames, EntityItems itemsToRetrieve)
at Microsoft.Uii.Customization.LandingPage.GetMetaDataDetails(EntityMetadata[] entityMetaDataCollection, String[] entityMetaDataNames)
at Microsoft.Uii.Customization.LandingPage.Page_Load(Object sender, EventArgs e)
at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
at System.Web.UI.Control.OnLoad(EventArgs e)
at System.Web.UI.Control.LoadRecursive()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
[HttpUnhandledException: Exception of type 'System.Web.HttpUnhandledException' was thrown.]
at System.Web.UI.Page.HandleError(Exception e)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest()
at System.Web.UI.Page.ProcessRequestWithNoAssert(HttpContext context)
at System.Web.UI.Page.ProcessRequest(HttpContext context)
at ASP.isv_uii_isv_microsoft_uii_customization_landingform_aspx.ProcessRequest(HttpContext context) in c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\fcc31ff6\e77f4ed8\App_Web_1qhxep8c.0.cs:line 0
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

whats going wrong here. Pls suggest asap.


May 25, 2010 at 4:30 AM

Hi astute25,


couple of quick questions .

1)When you browse the site " http://localhost:5555" (instead of server name try localhost)from the CRM Server machine which page it loads . Is it IFD Login Page ? It should load the page directly with out asking for credentials. Can you access the Landing Page ? This ensures that yours is IFD+Onpremise setup. If not you need to configure the IFD +OnPremise setup .

2) When you browse the site " http://servername:5555" from the CRM Server machine which page it loads . Is it IFD Login Page ? If it is IFD Login page , it is not correct , you need to do two steps. ALso if it prompting for credentials it is not correct.

                                 2.1) Disable IPv6

                                 2.2)Configure Loopback adapter

If this page directs to IFD Login page , then the landing page will throw the unauthorized error. you need to cross check these steps. Can you reply me with the findings .





May 25, 2010 at 10:48 AM

Hi arul,

In both the cases, while running on crm server machinge, it is redirecting automatically without asking for any credentials to the default organisation.

Iam pretty sure, it is configured nicely for IFD + On Premise.

So, now how can we get rid of the issue.

Pls suggest.

With regards


May 25, 2010 at 11:38 AM



Which user are you trying to login? System Admin or if any other user makes sure he has UII Administrator security role associated with him . If he is associated with UII Agent Security role , then he will not have permission .


And one more thing , when you browse using "http://localhost:5555" are you able to browse the landing page ? If not it should be with respect to the security roles permission. Makes sure he has Sys Admin or UII Administrator role associated with him.





May 25, 2010 at 1:50 PM

Hi arul,

Iam loggin in thru the user whois having sys_admin, system customizer, and uii administrator rights.

And ya , i can able to open the uii settings when accessing on crm server machine.

wtih regards



May 26, 2010 at 4:20 AM


"And ya , i can able to open the uii settings when accessing on crm server machine." So are you able to access using "http://localhost" or http://servername . I assume you are able to access it using localhost in crm server machine and not by server name . If this is the scenario it is clearly the Loopback adapter configuration which needs to be doneas suggested by prashanthi (2. Please follow this link , to setup the loopback address.).

Please add me in live messenger and we can discuss and close this.


May 26, 2010 at 5:54 AM

Hi arul,

"So are you able to access using "http://localhost" or http://servername " As i said earlier in both the cases it is properly resolving to the default organization.(without asking any credentials.)

But the organization for which iam installing this accelerator is not the default one.

Pls send me your live messenger id.

With regards




May 26, 2010 at 6:19 AM
Edited May 26, 2010 at 11:08 AM

discussed offline , Please rectify the IFD configuration .

Goal is to configure the setup for IFD+ OnPremise , if so the ifdurl from same domain should work with IWA , it should not prompt for credetials/IFD Credetials. Hope that solves your issue.

May 26, 2010 at 6:49 PM

Hi arul,

did exactly what we discussed offline. set the subnet successfully.

But the issue still not resolved.

Issue 1 : It is still asking for network credentials while accessing the ifd url both in server and in client(inside lan), but outside lan, it is working fine, as expected , going to login page.

Issue 2: On multiple organizations environment, what would be the url to access org. inside lan ? i checked the ifd url inside lan, and after giving the correct network credentials, it is pointing to the default organization instead of the organization iam mentioning. ex. is going to(after giving n/w credentials) to

And moreover i read related articles describing ifd+ on premise deployment using ifd tool. i came to know that it will make changes in web.config file . In which config , should it suppose to change.?the one under c:\program files\microsoft dynamics crm\crmweb\web.config ? If so , pls tell me the changes, because i didnt find any changes it did to the web.config file.

What is this mean. where iam going wrong.

thanks for your reponses, and pls sort it out soon.

With regards


May 27, 2010 at 5:18 AM
Edited May 27, 2010 at 5:18 AM

Hi Naren ,

As I mentioned this issue is due to IFD Configuration. You need to cross check all the steps not only the subnet mask. Please go through the IFD Configuration guide in the link

Issue 1 will go away once the IFD configurations are proper.

Issue 2 .. you need to access like . Hope that helps.


May 27, 2010 at 5:07 PM

HI arul,

Thanks for your responses. i think there might be some problems in ifd configuration in our end. we did lot of research and still it is asking for the network credentials. anyways will figure it out.

And one more thing about the agent desktop application, i am using the windows authentication on app.config, and it is authenticating it correctly.  I imported the data maps and imported all the data came with the application. But while debugging it, the hosted applications got failed to initialize and throwing error for each and every hosted application i installed and finally closing down the application.

ex. cannot create hosted application "session manager" contact administrator  (for all the applications it is showing this error message).

Iam logging with sys admin+uii admin user. what is the problem?

with regards



May 28, 2010 at 9:11 AM
Edited May 28, 2010 at 9:12 AM

Pl start a new thread for the same.

Just a quick reply. Check the hosted application configured location.